안드로이드 4.4(Android KitKat) 버전으로 프로젝트 생성 시 자동으로 appcompat_v7 이라는 프로젝트가 함께 생성됩니다.

appcompat_v7를 삭제하면 프로젝트에 와 함께 오류가 발생하여 오류 수정하기도 참 귀찮고 성가신 상황이 오게됩니다.


appcompat_v7를 없앨 수 있는 방법은 새로운 안드로이드 프로젝트를 생성할 때 Minimum Required SDK, Target SDK, Compile With 버전은 최신 버전으로 선택합니다.



프로젝트 생성이 완료된 후 기기가 4.4(키캣) 버전이 아닐 경우 빌드(Build)가 되지 않으므로 manifest 수정을 합니다.

위와 같은 부분을 아래와 같이 최소 요구 버전을 수정하시면 빌드하실 때에도 문제가 없습니다.


Posted by 준콩ol 준콩ol

댓글을 달아 주세요

  1. 배추머리 2014.08.02 06:02  댓글주소  수정/삭제  댓글쓰기


    좋은정보 감사합니다.

  2. 유태현 2014.09.02 11:24  댓글주소  수정/삭제  댓글쓰기

    3일 끙끙앎던거 해결!! 감사합니다...ㅠㅠ

  3. 글냥이 2014.11.02 11:00  댓글주소  수정/삭제  댓글쓰기

    저렇게 해도 상관 없는건가요?

    • 준콩ol 준콩ol 2014.11.03 08:00 신고  댓글주소  수정/삭제

      어떤부분에서 그렇게 해도 상관없는지 물으시는지 모르겠지만..
      뭔가 확실하지 않으시면 백업해 두고 시도했다가
      문제가 발생하면 다시 복원하시는 것을 추천드릴게요~

  4. 꿈꾸는별 2014.11.09 12:39  댓글주소  수정/삭제  댓글쓰기

    감사히 잘 봤습니다. 퍼갑니다.

  5. Basix 2014.12.16 16:40 신고  댓글주소  수정/삭제  댓글쓰기

    저렇게 하시면 호환 문제가 생길 수 있습니다 ㅇㅁㅇ..
    Kitkat의 구성 요소들을 이전 버전에서도 쓰게 하는게 목적이라...