Faceted Project Problem (Java Version Mismatch)

Description Resource Path Location Type Java compiler level does not match the version of the installed Java project facet.


위와 같은 오류 발생 시 조치방법입니다.


오류 발생 원인은 해당 프로젝트에 설정된 자바 컴파일러 버전과

현재 이클립스 프로젝트에 설정되어있는 자바 컴파일러의 버전이 일치하지 않아 발생하는 경우입니다.


1. 먼저 해당 프로젝트에 마우스 오른쪽 클릭 후 속성(Properties)으로 이동합니다.



2. Project Facets 메뉴에서 Java의 버전을 수정 후 OK 버튼을 클릭합니다.

  해당 프로젝트에 설정되어 있는 자바 버전을 변경하는 화면입니다.



3. 이번에는 2번 내용과 반대로 Java compiler 버전을 해당 프로젝트에 설정된 버전에 맞추려면 Java Compiler 메뉴에 Compiler compliance level을 변경하여 적용할 수 있습니다.

Posted by 준콩ol 준콩ol

댓글을 달아 주세요